Jump to content


NEW custom search, includes forums, wiki, github issues, TC sourcecode, irc logs, doxygen automated documentation; read more here
Photo

Making my Trinity Server Public.


  • Please log in to reply
21 replies to this topic

#1 Cplusplusnoob

Cplusplusnoob

    Advanced Member

  • Members
  • PipPipPip
  • 47 posts

Posted 27 April 2011 - 07:23 PM

Hello, I've been working at this for 2 days now, I have tried a few tutorials and haven't had any success.
Here is a layout of what I have done to get my server public, maybe someone could see the error I have made/overlooked and know what I need to do to get this going. Anyone that could assist here, or maybe one step further on Team Viewer, I would be forever in your debt :D

1. Opened the following Ports on my router/modem.

BOTH TCP/UDB 80 - 80

BOTH TCP/UDB 3036 - 3036

BOTH TCP/UDB 3306 - 3306

BOTH TCP/UDB 3724 - 3724

BOTH TCP/UDB 3443 - 3443

BOTH TCP/UDB 6112 - 6112

BOTH TCP/UDB 7878 - 7878

BOTH TCP/UDB 6881 - 6999

BOTH TCP/UDB 8050 - 8050

BOTH TCP/UDB 8085 - 8085

BOTH TCP/UDB 8093 - 8093

BOTH TCP/UDB 8129 - 8129

2.Got a DNS xxxxExternal Ip, xxxxRealmlist


3. Edited my Host file<-----Have a feeling this may be where my problems arise.

# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost
174.91.xx.xxx(external Ip) xxxxxxxx.dyndns.org
192.xxx.x.xx(IP) xxxxxxxx.dyndns.org


4.Edited the Realmlist on my Auth DB to my External Ip address.

After completing all these steps I'm unable to login to the world server on my host or from another computer. The only way I can get on is if I have my DB realmlist set to 127.0.0.1 and my wow folder realmlist to 127.0.0.1. Additional information I'm running Windows Xp Home Edition 32 bit, and have my Windows Firewall turned off and have Norton Internet Security 2011, but even with all security options disabled, no luck. I am also using a 2Wire Gateway dual Modem/Router, provided by my ISP Bell, all the ports I have listed were opened there.

Edited by Cplusplusnoob, 27 April 2011 - 07:25 PM.


#2 Inceptionz

Inceptionz

    Advanced Member

  • Members
  • PipPipPip
  • 142 posts

Posted 27 April 2011 - 07:28 PM

I don't think you'll get support for public servers here.

#3 Cplusplusnoob

Cplusplusnoob

    Advanced Member

  • Members
  • PipPipPip
  • 47 posts

Posted 27 April 2011 - 07:38 PM

I don't think you'll get support for public servers here.



I have my laptop setup to run the server, I just want to be able to play the server on a separate computer so it's not laggy. I don't see why this is a big deal.

#4 One0

One0

    Advanced Member

  • Members
  • PipPipPip
  • 196 posts

Posted 27 April 2011 - 07:49 PM

TrinityCore dont support Public Server!
Given enough eyeballs, all bugs are shallow.

#5 Cplusplusnoob

Cplusplusnoob

    Advanced Member

  • Members
  • PipPipPip
  • 47 posts

Posted 27 April 2011 - 07:51 PM

TrinityCore dont support Public Server!



K bruh, I was looking for support from the public, not Trinity Staff. Go ahead and close the topic.

#6 Brian

Brian

    Advanced Member

  • Members
  • PipPipPip
  • 540 posts

Posted 27 April 2011 - 07:56 PM

Actually how else is you brother out in Vegas going to connect to play with you.

I think someone on this thread needs to read the definitions of public server and private server again...

Public: Has a website that allows registrations, allows connections from people they don't know, accepts donations, makes a shit ton of cash. (any and or all of these).

Private: Can be accessible from the Internet but doesn't advertise as such. Manual registration.

You are correct, we don't support public servers, however, what I am seeing in this thread is a private server.

-- Brian

#7 Paradox

Paradox

    Know it all

  • Members
  • PipPipPip
  • 2,795 posts

Posted 27 April 2011 - 08:24 PM

I can tell that you have been reading some shady guides that don't apply to TC, for one , NEVER forward your MySQL port unless you need to explicitly access it remotely, and, if you do, change it to some port other than 3306, or you are inviting people to hack your server, secondly, the only ports that TC needs forwarded are 3724, 8085, 3443 for RA and 7878 for SOAP (these last two are not needed if you don't use RA or SOAP) 8129 I see a lot, and usually comes from people running repacks of ArcEmu (possibly a backdoor)

Also, Brian, if this is not a post about a public server, why does he need port 80 forwarded?

#8 One0

One0

    Advanced Member

  • Members
  • PipPipPip
  • 196 posts

Posted 27 April 2011 - 08:40 PM

I agree with Paradox about forward. Port 80 is for apache. If you want make private server you dont need forward this port. If you use public server and you want allow people who you dodnt know to play on your server you have to forward port 80.
Given enough eyeballs, all bugs are shallow.

#9 Athena

Athena

    Advanced Member

  • Moderators
  • 2,284 posts

Posted 27 April 2011 - 08:42 PM

First, you don't have to open those ports on your router... but forward them to your fixed ip host running TrinityCore.
Second, you can't have 2 IP's address configured to the same DNS name on your host file, what you can do is:

On your auth database, realm table put your DNS instead of your IP address.
On your host file, put the local IP address of the server followed by the DNS name (ONLY), if you get out of your local network, just comment that line.
On your router, if i understand correctly you managed your firewall to open those ports... reset those definitions and go to port forwarding and forward only the 3724 and 8085 ports to your TrinityCore host.

After this, you should connect correctly.

#10 thunder1

thunder1

    Advanced Member

  • Members
  • PipPipPip
  • 46 posts

Posted 27 April 2011 - 09:06 PM

Is your DNS correctly pointed to the IP of the server? That could be another issue regards to external access. The steps outlined by Athena should give you local and network access for sure though.

#11 Watapus

Watapus

    Member

  • Plebs
  • PipPip
  • 14 posts

Posted 16 February 2013 - 07:17 PM

Nvm needed to enter IP and not DNS into realmlist db


Edited by Watapus, 16 February 2013 - 11:07 PM.


#12 Posthumus

Posthumus

    Advanced Member

  • Members
  • PipPipPip
  • 1,102 posts

Posted 17 February 2013 - 02:08 AM

@Watapus, my dns resolves just fine in my realmlist DB.


The box said "Requires Windows XP or better." So I installed Linux...

#13 Watapus

Watapus

    Member

  • Plebs
  • PipPip
  • 14 posts

Posted 17 February 2013 - 02:12 AM

Hm interesting, when I had the DNS in the realmlist when I was testing a TBC server it was allowing my buddy to connect just fine. Then I bumped it up to WOLK and it only allows for him to connect when I use my IP and not DNS.

 

I have all my .conf files set to the DNS and they are working just fine.



#14 Paradox

Paradox

    Know it all

  • Members
  • PipPipPip
  • 2,795 posts

Posted 17 February 2013 - 10:42 AM

Yeah, I think someone changed the way the authserver works since TBC... There are ways of finding out who, and what commit did it, should also not be too hard, since the authserver doesn't usually get a whole lot of changes.



#15 Watapus

Watapus

    Member

  • Plebs
  • PipPip
  • 14 posts

Posted 17 February 2013 - 05:14 PM

Yeah, I think someone changed the way the authserver works since TBC... There are ways of finding out who, and what commit did it, should also not be too hard, since the authserver doesn't usually get a whole lot of changes.

Awesome I'll take a look then. Thank you :D.



#16 Posthumus

Posthumus

    Advanced Member

  • Members
  • PipPipPip
  • 1,102 posts

Posted 18 February 2013 - 08:12 PM

The current revision of authserver works for the TBC and TC (3.3.5a) sever that I am running... What revision of TC and TBC are you using?


The box said "Requires Windows XP or better." So I installed Linux...

#17 Paradox

Paradox

    Know it all

  • Members
  • PipPipPip
  • 2,795 posts

Posted 18 February 2013 - 10:16 PM

The current revision of authserver works for the TBC and TC (3.3.5a) sever that I am running... What revision of TC and TBC are you using?

 

I think you missed the point, try using www.blah.noip.com instead of your IP in the realmlist.address column...



#18 Posthumus

Posthumus

    Advanced Member

  • Members
  • PipPipPip
  • 1,102 posts

Posted 18 February 2013 - 10:44 PM

I think you missed the point, try using www.blah.noip.com instead of your IP in the realmlist.address column...

 

If I use WWW.xxxxx.xxx.COM it does not work, however, stripping the "http://www" seems to work.

Example: xxxxx.xxx.COM works. No idea why that was changed within the past year, but the DNS is working.


The box said "Requires Windows XP or better." So I installed Linux...

#19 PanikAttak

PanikAttak

    Newbie

  • Plebs
  • Pip
  • 2 posts

Posted 28 June 2013 - 08:55 PM

I want to start by saying thank you to the developers of Trinity for their hard work. 

 

Now on the topic of making your server public so your friends can join...I have had all the issues that everyone else is posting about. It has frustrated me for MONTHS(probably around Aug/Sep time frame of last year is when i started trying this. Started first with Arcemu and then Jeuties and could never get it the way i wanted. Few days ago I decided to go with pure trinity and it was just as frustrating.

 

My Goal: Run server on my Server PC, Play from my gaming PC, Let my brother connect to play with me from the States.

 

It has taken me a long time to achieve this and if you are having the same issues here is what i did:

 

I followed all the instruction that Athena and CDawg posted, forward ports to my server pc, make sure firewall exceptions are made, left auth and world conf files alone (0.0.0.0 default to bind all IPs).

 

Now to the good part, I tried my external IP in the address field in auth/realmlist database...didnt work. Tried my dns in the auth/realmlist database...didnt work.

 

I started looking at the database and noticed the 4th column...localAddress...after trying everyother combination i could think of before seeing this column i decided what the hell...i put my servers local network IP...192.168.xxx.xxx...and what do you know...after setting my gaming computers realmlist to the local address of the server i can connect...my brother puts my DNS in his wtf file and now he can connect from outside my network...

 

After months of fiddling and looking for solutions...i think i have found whateveryone else has been looking for.

 

Hopefully this helps all you.

 

PS. this solution does not allow you to run your server and play from the same machine...if that is an issue i suppose you can leave your localAddress column as 127.0.0.1



#20 Posthumus

Posthumus

    Advanced Member

  • Members
  • PipPipPip
  • 1,102 posts

Posted 29 June 2013 - 06:41 AM


PS. this solution does not allow you to run your server and play from the same machine...if that is an issue i suppose you can leave your localAddress column as 127.0.0.1

 

Why not?

If you modify the local .wtf to the same settings as what your brother, or someone outside has that setting at, than I don't see why this wouldn't work.


The box said "Requires Windows XP or better." So I installed Linux...